Arma

e39 530i tidy up + mods

144 posts in this topic

Where's the pics?

Also keen on having a listen to this setup.

Plan to get some up tonight (crappy pics from phone probably). Yeah definitely - can organize a catch up or if I manage to show up to the sunday meet can listen there. Or just come to the damn shisha restaurant/bar in chancery since I'm pretty much there every evening :D

Share this post


Link to post
Share on other sites

Some [crappy] pics of the headunit. Currently set the color of it to amber / similar to the rest of the BMW interior lights, but these are changeable to any colour (can make up your rgb values i believe).

21205047874_41da1b1da0_b.jpg

21206724053_88e836ff00_b.jpg

21827755635_722704df5c_b.jpg

Share this post


Link to post
Share on other sites

Wow. Not a good start to the day... Tried dodging a van inside a parking lot and skimmed a pole. Guess I need a new left rear door trim, and a repaint. :-( If anyone knows where I might be able to get just a single trim let me know!


21950119435_fe05550490_b.jpg

1 person likes this

Share this post


Link to post
Share on other sites

That sucks!

Looks like it needs a bit of panel beating work too.

Share this post


Link to post
Share on other sites

That sucks!

Looks like it needs a bit of panel beating work too.

Ya. The dent on the door is very subtle - so not a major on that side, but will defo need a repaint. Cheap option would be to get new black trim, do quick dent repair to straighten out the small door dent, and fill paint scratches with filler paint. But when it comes to panel/paint I don't tend to take the cheap option :<

1 person likes this

Share this post


Link to post
Share on other sites

Haven't updated this for a whiile!

Did an engine oil and filter service last month and also changed the thermostat (for like the 4th time in 2 years) due to it leaking constantly.

I thought that had concluded my entire cooling system but looks like I might have another coolant leak now... and maybe a belt problem.

First thing I noticed was something under the bonnet started squealing very loud when driving occasionally - figured something is up with the belts (though all my belts have been replaced a year ago) and/or pulleys -> my idler pulley did seem to have a very slight wobble last time i checked. Not sure where exactly the squeal is coming from since it goes away every time im about to check under the bonnet.. but perhaps it's related to that idler pulley. What I did notice was small amount of coolant spray on my air intake box , sprayed from coolant falling on the belt I'd say, which is exactly what happened when my old thermostat was leaking. Better not be the new thermostat leaking too - I'm sick of changing thermostats :D . Perhaps the squeal is being caused by coolant falling on the belt. Will need to take it in to have it checked out. There seems to be quite a lot of info regarding squealing sounds in e39s online, all pointing to all sorts of different things but mainly around the belt being bad.

Drive and feel still feels normal. The squealing sound is just bloody annoying when it appears sometimes.

I had my waterpump replaced just few months ago as well, and I checked it for leaks when changing the thermostat and it seemed all good. All the main hoses are new as well, along with radiator etc. I guess coolant leaks just love me. :ph34r:

1 person likes this

Share this post


Link to post
Share on other sites

is it the thermostat leaking or is it the radiator hose not sealing properly??? as when i replaced my thermostat i found the o-rings in the hose didnt want to seal completely again

Share this post


Link to post
Share on other sites

Drive and feel still feels normal. The squealing sound is just bloody annoying when it appears sometimes.

Loosen the belt tensioner(s) and spin the pulleys by hand to see if/which one is making the noise.

3 people like this

Share this post


Link to post
Share on other sites

Thanks all.

Loosen the belt tensioner(s) and spin the pulleys by hand to see if/which one is making the noise.

Yeah i might need to do this. Haven't had the chance yet.

The squeal has been pretty on and off. Last few days i've heard it like once or twice, and it lasted for a total of 10 seconds. Seems to stop when i put the car into neutral / when not moving. But one of the times when the car was stand still it still squealed, so might just be coincidence/unrelated.

Share this post


Link to post
Share on other sites

Got this fixed at Glenn's this week (Botany Motorworxx), thanks! The one time I needed the squealing sound to appear, it decided not to. So after using a stethoscope we could tell the idler pulley and tensioner pulley bearings were pretty much on their way out. The sound was most likely coming from the idler pulley - just couldn't replicate it that day, despite it squealing its butt off the day before.

Belts were still in good condition, so just replaced the idler pulley and the pulley for the tensioner. I have the hydraulic tensioner in the car, so only needed to change the pulley instead of the whole tensioner unit.

Also sorted out a small oil leak coming from the exhaust cam sensor - o-ring replacement. Odd as I just replaced it a few months ago. Glenn did a pressure test on the cooling system since I suspected a leak, but did not find anything. I generally have been topping up my coolant by half a litre every 3 weeks or so, so nothing major.

The day before the pulley fix I managed to get a recording of the squeal sound if anyone finds it useful:

Edited by Arma

Share this post


Link to post
Share on other sites

Been over a year since I posted here. Been busy riding motorcycles lately so haven't done much with the car. :ph34r:

No good news to post - my yellow check engine light has come on and will need to be scanned. I don't really want to drive it far with the light on just in case, so might just have to take it in to BM Workshop, which is closeby for me, for the scan to identify what the actual issue is. Engine seems to be running fine, no rough idles, no rough anything, no loss of power etc. Hopefully just an o2 sensor or vac hose, but who knows :-). Getting it scanned tomorrow (I should get my own scanner already!)

Apart from that, taking the car to panel shop end of the month to get all those dents (door and side skirt) sorted out.

1 person likes this

Share this post


Link to post
Share on other sites

Kyu was kind enough to come over with his scanner (thanks). Error code was a P0444 - Evaporative Emission System Purge Control Valve Circuit Open.

We cleared the code. I tightened my fuel tank lid (in case there is a sensor there somewhere, I don't know). Engine light hasn't come on since - have done some motorway driving, city driving etc.

Will wait and see if it still comes on again at some point.. hopefully not.

1 person likes this

Share this post


Link to post
Share on other sites

How long have you had this car for now? Must be a few years! 

1 person likes this

Share this post


Link to post
Share on other sites
3 hours ago, Michael. said:

How long have you had this car for now? Must be a few years! 

Over 4 years now :-)

1 person likes this

Share this post


Link to post
Share on other sites

Time flies :P 

Still a great car.

Between the E34 and E39, the best looking 5 series. 

New ones strike me as just generic big cars... :( 

2 people like this

Share this post


Link to post
Share on other sites

Bad luck - check engine light has come back on.

Will find some time during the week to visit Glenn probably and hope it's nothing major. Seems like 20+ mins of motorway driving throws the light on. Everything was fine city driving and idling etc. Research shows the code is related to the Evap Canister Purge Control Valve - if it's that then it looks like an easy job to fix (valve sits under the intake manifold, so have to take air intake box off, disconnect maf etc.).. will see what we found out once it is in the shop.

Edited by Arma
1 person likes this

Share this post


Link to post
Share on other sites

It seems I have not run out of bad luck yet this year, just a few days left. Apart from the CEL, and the lock barrels breaking in the car, and of course my motorcycle accident 3 weeks ago where I shattered my elbow and thumb.. last night car got broken into at Chancery car park, in the CBD. 2 laptops, gopros, xbox stuff and expensive pair of headphones stolen. I never leave laptop on the seat area, but since my boot doesnt open at the moment, I did - inside a black laptop bag. Already reported to police.

Be safe out there people, thieves around as usual but more due to holiday season. 

No automatic alt text available.

Edited by Arma

Share this post


Link to post
Share on other sites

D'oh!

1 person likes this

Share this post


Link to post
Share on other sites

F@#& dude, I really hope 2018 works for you, the end of '17's really let you down! :(

 

4 people like this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now