Jump to content
M3AN

MSS50 DME Errors - Thoughts?

Recommended Posts

E36 3.2 M3.

Codes come back after being cleared when engine is restarted and idling.

Potentially related symptoms (only potential symptoms actually):

* Engine cuts momentarily (will shut down if this occurs at idle) - used to be only occasionally (infrequently) and at low revs, now more frequently and across rev range. Oil level light comes on when this happens but no other warning/telltale lights. Oil level indicator extinguishes after a few seconds. Actual oil level is fine.

* Smell of unburnt fuel from engine bay area, no obvious leaks.

Any ideas?

 

MSS50Faults.jpg

Share this post


Link to post
Share on other sites

Doesn't look ideal...

Any recommendations on how to test these things or who could take a look?

DMEHmm.jpg

Edited by M3AN

Share this post


Link to post
Share on other sites

Will message you a guy who can solve, only deals with the trade now

Edited by E30 325i Rag-Top
  • Like 1

Share this post


Link to post
Share on other sites

So, I got my ECU back and the experts said that what's in the picture above wasn't the problem, that just needed a bit of a clean.

But they did find a itsy, bitsy, teeny, tiny component that was busted... it was way smaller than a typical ant, no chance I would have spotted it or been able to fix it myself.

Car is in parts but am hoping to plug it in and at least turn her over on the weekend to see what happens...

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×