Jump to content
keen

Need help here please

Recommended Posts

My racecar E30 has a M50B20 fitted. That part is all good. The car runs 99% good. But there  an annoying problem that it has and I am into starting from scratch to try and locate it. At this point the problem is not my main focus right now. I could be barking up the wrong tree but please give me the chance to trouble shoot from the bottom up. The car was dyno'ed and the mechanic has suggested to keep costs down I go away and look for some suggested  things myself. The main thing he found was he couldn't talk to the ECU through the  diagnostic plug  although it did power up. I have been tasked with tracing all the pins back to the ECU. That part I can do. the part I cant do is google find the pins in the plug that relate to the pin numbers on the plug that goes into the ECU.

Can someone just tell me what pins in the diagnostic 20 pin plug go to the ECU plug numbers   and maybe the colours of the relevant wires PLEASE. There are only 6 sockets with connections  in the Diagnostic plug. 

Share this post


Link to post
Share on other sites

Thank you but Im still having trouble with the id at the plug.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...