Jump to content
Sign in to follow this  
Bigmor

iDrive Firmware upgrade

Recommended Posts

Today I had my firmware upgrade on my 2009 BMW 135I to be like a NZ new model and replace the japan software that it had on it. Everything went fine and I got radio + Navigation through a place in town which does work for our local BMW franchisee. However, on driving away the sound quality was really poor (No bass and really quiet) and the radio reception was really poor....my gut feeling from putting in older style radios in older style cars, was cables were in backwards or similar, but the electrician assured me that could happen with this.

He is getting some software/computer to do some testing on Monday...but really interested to know what your thoughts are on this and what may have caused it?

Share this post


Link to post
Share on other sites

Today I had my firmware upgrade on my 2009 BMW 135I to be like a NZ new model and replace the japan software that it had on it. Everything went fine and I got radio + Navigation through a place in town which does work for our local BMW franchisee. However, on driving away the sound quality was really poor (No bass and really quiet) and the radio reception was really poor....my gut feeling from putting in older style radios in older style cars, was cables were in backwards or similar, but the electrician assured me that could happen with this.

He is getting some software/computer to do some testing on Monday...but really interested to know what your thoughts are on this and what may have caused it?

I guess you have CIC equipped car, the JAPAN CIC radio tuner hardware is different to European model, the normal software conversion will result poor radio reception. We do have solution to fix it. For sound quility issue, it maybe caused by wrong coding

Share this post


Link to post
Share on other sites

Hi there,

I am based in Wellington, can you fix remotely and what is the cost? It sounds like both has happened to my car...I don't have any bass in car and seems like the speaker in the back...from what I have read, the speakers under the seat aren't making sound now.

Cheers,

Share this post


Link to post
Share on other sites

Hi there,

I am based in Wellington, can you fix remotely and what is the cost? It sounds like both has happened to my car...I don't have any bass in car and seems like the speaker in the back...from what I have read, the speakers under the seat aren't making sound now.

Cheers,

yes, we can fix it for you. contact us via phone to schedule a time. we also need some more info about your car and current spec

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×