Search the Community

Showing results for tags 'coolant'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • New Member Introductions
    • General Discussion
    • News
    • Off-Topic
    • Other European Cars
  • BMW Race Series
    • Race Series - General Discussion
    • Race Series - Technical
  • Track Days
    • Track Day Events
    • Vehicle Setup
  • Technical
    • Performance
    • Maintenance
    • Brakes, Suspension & Steering
    • Wheels & Tyres
    • Appearance
    • Audio & In Car Entertainment
    • Forced Induction & Performance Tuning
    • Electrical system
    • Interior
    • Engineering/Fabrication
  • Rides
    • Showroom
    • Videos & Sound
    • Projects
  • Marketplace
    • For Sale
    • Want to buy
    • Sponsors & Preferential Rates.
    • TradeMe discussions
  • bimmersport.co.nz
    • Forum Help and Support

Calendars

  • Bimmersport Community Calendar

Name


Location


Car


Mods List


Car 2


Car 3


Race Car


Race Car Number

Found 3 results

  1. I've read of some the common issue with these, expansion tank, radiator side tanks, temperature sensor o'ring and dont seem to have any of these problem. There is a tiny little bit of white residue on the expansion tank but it doesnt seem to get bigger yet i still lose maybe 100-200ml over an open road journey of about 50km. I read here that the heater matrix can also be a problem but dont have a coolant smell inside and dont appear to have any water inside either. Ive had a good look around the block and cant see anything obivous. I did take than fan and shroud off and had a good look on the inside of the radiator and it looked clean and dry - should it take it right out and look from the other side? Does anyone have any other suggestions in what to look for? Thanks Very small amount of white staining at top of radiator header tank Header tank stain up close Expansion tank looks fine
  2. Ladies and Gentlemen, Ok so as some of you may have guessed i have a E60 545I. currently everyweek i am having to top up my coolant by at least 1tr, there is the apperance of liquid and dried antifreeze coming from the small drain hole to the top left of the water pump. My best guess is the Cooland Transfer Pipe seal has failed and getting worse. I have read the horror stories online about the 3K+ repair bill to have this fixed, i've been on Ebay and looking to get one of the many third party repair kits. My question is has anyone done this repair, maybe purchased a kit and can offer some advise or knows of a local NZ company that has these kits or even has purchased a kit and didn't use it. Any suggestions, advise or even some direction is greatly appreciated.
  3. Hey there, Went to check my oil levels today and noticed a small puddle of coolant near the bottom of the head! I wiped it clean to see if I could locate the source. I noticed it was leaking out from what looks to be the head - I'm not a car buff! :S If anyone could put me in the correct direction, It would be much appreciated! Cheers.