Jump to content

Search the Community

Showing results for tags 'audio'.

More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • General
    • New Member Introductions
    • General Discussion
    • News
    • Off-Topic
    • Other European Cars
  • BMW Race Series
    • Race Series - General Discussion
    • Race Series - Technical
  • Track Days
    • Track Day Events
    • Vehicle Setup
  • Technical
    • Performance
    • Maintenance
    • Brakes, Suspension & Steering
    • Wheels & Tyres
    • Appearance
    • Audio & In Car Entertainment
    • Forced Induction & Performance Tuning
    • Electrical system
    • Interior
    • Engineering/Fabrication
  • Rides
    • Showroom
    • Videos & Sound
    • Projects
  • Marketplace
    • For Sale
    • Want to buy
    • Sponsors & Preferential Rates.
    • TradeMe discussions
  • bimmersport.co.nz
    • Forum Help and Support


  • Bimmersport Community Calendar




Mods List

Car 2

Car 3

Race Car

Race Car Number

Found 2 results

  1. Hi there, I have an E46 and the sound system has an issue. It will play the radio just fine for about 30 minutes, but then the front and rear woofers cut out all at once, and then not long after, the rest of the speakers all cut out too. I got home and left the car off for about half an hour, and the sound all came back. Has anyone else had this issue? Is it likely to be the amplifier chips overheating or something? If so, where is the best place to get a replacement? Thanks.
  2. Hey! Does anyone know or have those plastic clips that go in the passenger dashboard (the orange clips) thats are in the image below - I took mine off to install my headunit but they have dried out and cracked Its for a 318i 98' e46 Sedan