Jump to content
DreDurk

Loss of power

Recommended Posts

Hey

My N52 E90 has been having issues. 
Could most likely be VANOS solenoid. I have been cleaning these multiple times in the last month. Worked the first time but recently it has got worst. Looking at buying 2 new. But could there be anything else.???

EXAMPLE OF POWER LOSS

Car likes the stay within 2k rpms when cruising and has serious hiccups when increasing and decreasing speeds. When shifting into DS the car rpms go from 2000 to 3500-4000 within a blink. Car idles around 600 which I have seen is normal. Starts up perfectly fine. Yesterday I took out the VANOS solenoid I the morning (Car hasnt started up yet) to check again and the oil was black n smelt burnt. I am changing this within a few days. But this is a first with it being dark n burnt smell.

Any ideas guys what might be the issue besides VANOS?. 
All help is appreciated.

Share this post


Link to post
Share on other sites

Have you had it scanned ?.....Note: Fault codes and live data, not just a "P" code reader list

Share this post


Link to post
Share on other sites
33 minutes ago, B.M.W Ltd said:

Have you had it scanned ?.....Note: Fault codes and live data, not just a "P" code reader list

Recently had it scanned 2 Friday’s ago. Nothing came up, got it scanned as I had a long road trip that weekend. Made sure it was okay before. I have recently bought myself a scanner but in transit...

Share this post


Link to post
Share on other sites

It could be loads of things. Unless you scan the car with a proper scan tool or even better, ISTA  and get the fault codes, then you are pretty much banging your head against a wall. A cheap ass code reader won't do the job.

Share this post


Link to post
Share on other sites

@Driftit same symptoms as yours?

Share this post


Link to post
Share on other sites
9 hours ago, GorGasm said:

@Driftit same symptoms as yours?

I have no loss of power. But a loss of power would result in a code of some kind.

If the hiccups are actually misfires you will have a code. The Vanos and valvetronic motor will also both throw codes and will both cause a loss of power. 

Only reason mine wasn't throwing codes was because it was actually the Torque converter playing up. 

As others have said get someone with INPA or ISTA to scan the car. 

Edited by Driftit
  • Like 1

Share this post


Link to post
Share on other sites
On 7/29/2020 at 5:53 PM, Driftit said:

I have no loss of power. But a loss of power would result in a code of some kind.

If the hiccups are actually misfires you will have a code. The Vanos and valvetronic motor will also both throw codes and will both cause a loss of power. 

Only reason mine wasn't throwing codes was because it was actually the Torque converter playing up. 

As others have said get someone with INPA or ISTA to scan the car. 

I got this scan back with my own. Both right n left front speed sensors have triggered too. 

4ACC3A79-758F-4358-B495-8AEFE4384456.jpeg

Share this post


Link to post
Share on other sites

Oh right. That's the DSC (stability control) . Shouldn't get a loss of power from that at all. 

Still something you should look into though. No ABS light on? 

Share this post


Link to post
Share on other sites
Just now, Driftit said:

Oh right. That's the DSC (stability control) . Shouldn't get a loss of power from that at all. 

Still something you should look into though. No ABS light on? 

No ABS light, but vividly remember it popping up a couple times a few months ago. But that was when I had my old battery which had a bad battery cell. I was removing it from my car to trickle charge it every 2-3 days. Could my IBS be it? There are other faults too (as of today’s date) but 99% of these faults are electrical issues. F70B1001-B8CD-4A59-BF02-8B0763504753.thumb.png.e88f0c93812fb1a831577d029c778203.pngF70B1001-B8CD-4A59-BF02-8B0763504753.thumb.png.e88f0c93812fb1a831577d029c778203.png

ACF72FA7-E648-41C0-A037-70A89953913E.png

54ABD550-1D9E-4E2C-AE3A-3B12B43FB164.png

Share this post


Link to post
Share on other sites
10 minutes ago, Driftit said:

Oh right. That's the DSC (stability control) . Shouldn't get a loss of power from that at all. 

Still something you should look into though. No ABS light on? 

This has all happened within the 10th of July this year. Sutherland Performance wellington scanned my car and nothing came up. No check engine light until I got halfway on my trip up north. (Which was a fright) only maintenance some was install new battery...n check my suspension n came back with my RH control arm bush is worn.

Share this post


Link to post
Share on other sites
17 hours ago, Driftit said:

Oh right. That's the DSC (stability control) . Shouldn't get a loss of power from that at all. 

I thought the first action DSC took was reducing power, followed by applying the brakes? I certainly know DSC can control engine output so I wouldn't be too quick to rule it out.

@DreDurk - that's a lot of codes... keep a copy, clear them all, start car, stop car, check codes, keep a copy, clear all codes, go for a drive (to the point where the car is at operating temp) and then check codes again... what are you left with?

Obviously only take if for a drive if it sounds okay.

Share this post


Link to post
Share on other sites
1 hour ago, M3AN said:

I thought the first action DSC took was reducing power, followed by applying the brakes? I certainly know DSC can control engine output so I wouldn't be too quick to rule it out.

@DreDurk - that's a lot of codes... keep a copy, clear them all, start car, stop car, check codes, keep a copy, clear all codes, go for a drive (to the point where the car is at operating temp) and then check codes again... what are you left with?

Obviously only take if for a drive if it sounds okay.

Cheers for the info man, appreciate it and I’ll keep you updated via this thread. 
Also, could the type of fuel company im using effect this? I mainly use waitomo, 91, I’ve heard these places use 10% ethanol blend? Which could be why it’s so dirt cheap most times? 

Share this post


Link to post
Share on other sites
1 hour ago, DreDurk said:

Cheers for the info man, appreciate it and I’ll keep you updated via this thread. 
Also, could the type of fuel company im using effect this? I mainly use waitomo, 91, I’ve heard these places use 10% ethanol blend? Which could be why it’s so dirt cheap most times? 

91?? 91 is for Toyotas and tight asses. Run it on 95 at least. 

  • Like 2

Share this post


Link to post
Share on other sites

Yup never run a BMW on that crap. 95 at a minimum. 

Share this post


Link to post
Share on other sites
20 hours ago, F10er said:

91?? 91 is for Toyotas and tight asses. Run it on 95 at least. 

Actually most generic Toyotas you hear driving around are constantly pinging from stationary, anything vvti with 10.5+ compression usually has a sad life once they come to NZ from Japan. They should all be run on 95 at a minimum.

 

Edited by Michael.
  • Like 4

Share this post


Link to post
Share on other sites
21 hours ago, Michael. said:

Actually most generic Toyotas you hear driving around are constantly pinging from stationary, anything vvti with 10.5+ compression usually has a sad life once they come to NZ from Japan. They should all be run on 95 at a minimum.

 

We shouldn't have 91 at all. You would struggle to find low grade fuel like 91 in Japan. 

  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, Driftit said:

We shouldn't have 91 at all. You would struggle to find low grade fuel like 91 in Japan. 

Agreed. Its interesting to note that there are a few NZDM cars still being sold that spec 91 and are obviously crippled to run on it. The Mitsubishi Eclipse Cross is a prime example. 10:1 CR, 1.5L turbo, specced for 91. According to Wiki our ones are 11hp down on the rest of the world.

  • Like 2

Share this post


Link to post
Share on other sites

Back in the day before 98 we would savoir every drop of fuel that was in the tank of fresh imported Evo's, SIlvia's, Skylines.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...